<!DOCTYPE html>
<html lang="en" dir="ltr" >

<head>
  <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<link rel="apple-touch-icon" href="//www.simpsoncounty.ms/sites/default/files/Magee-favicon_1.png" type="image/png" />
<meta property="og:type" content="Article" /><meta property="og:title" content="Primary Election Tuesday"/><meta property="og:url" content="https://www.simpsoncounty.ms/front-page-slideshow-news/primary-election-tuesday"/><meta property="og:image" content="//www.simpsoncounty.ms/sites/default/files/header 2017.jpg"/><meta property="fb:admins" content="dgustoughson"><meta name="Generator" content="Drupal 7 (http://drupal.org)" />
<link rel="canonical" href="/front-page-slideshow-news/primary-election-tuesday" />
<link rel="shortlink" href="/node/5018" />
<link rel="shortcut icon" href="//www.simpsoncounty.ms/sites/default/files/Magee-favicon_2.png" type="image/png" />
  <title>Primary Election Tuesday | Magee Courier-Simpson County News</title>  
  <style type="text/css" media="all">
@import url("//www.simpsoncounty.ms/modules/system/system.base.css?pvi6v4");
@import url("//www.simpsoncounty.ms/modules/system/system.menus.css?pvi6v4");
@import url("//www.simpsoncounty.ms/modules/system/system.messages.css?pvi6v4");
@import url("//www.simpsoncounty.ms/modules/system/system.theme.css?pvi6v4");
</style>
<style type="text/css" media="all">
@import url("//www.simpsoncounty.ms/misc/ui/jquery.ui.core.css?pvi6v4");
@import url("//www.simpsoncounty.ms/misc/ui/jquery.ui.theme.css?pvi6v4");
@import url("//www.simpsoncounty.ms/misc/ui/jquery.ui.button.css?pvi6v4");
@import url("//www.simpsoncounty.ms/misc/ui/jquery.ui.resizable.css?pvi6v4");
@import url("//www.simpsoncounty.ms/misc/ui/jquery.ui.dialog.css?pvi6v4");
</style>
<style type="text/css" media="all">
@import url("//www.simpsoncounty.ms/modules/aggregator/aggregator.css?pvi6v4");
@import url("//www.simpsoncounty.ms/sites/all/modules/calendar/css/calendar_multiday.css?pvi6v4");
@import url("//www.simpsoncounty.ms/sites/all/modules/date/date_api/date.css?pvi6v4");
@import url("//www.simpsoncounty.ms/sites/all/modules/date/date_popup/themes/datepicker.1.7.css?pvi6v4");
@import url("//www.simpsoncounty.ms/modules/field/theme/field.css?pvi6v4");
@import url("//www.simpsoncounty.ms/modules/node/node.css?pvi6v4");
@import url("//www.simpsoncounty.ms/modules/search/search.css?pvi6v4");
@import url("//www.simpsoncounty.ms/sites/all/modules/simpleads/simpleads.css?pvi6v4");
@import url("//www.simpsoncounty.ms/sites/all/modules/ubercart/uc_order/uc_order.css?pvi6v4");
@import url("//www.simpsoncounty.ms/sites/all/modules/ubercart/uc_product/uc_product.css?pvi6v4");
@import url("//www.simpsoncounty.ms/sites/all/modules/ubercart/uc_store/uc_store.css?pvi6v4");
@import url("//www.simpsoncounty.ms/modules/user/user.css?pvi6v4");
@import url("//www.simpsoncounty.ms/sites/all/modules/views/css/views.css?pvi6v4");
</style>
<style type="text/css" media="all">
@import url("//www.simpsoncounty.ms/sites/all/modules/ed_classified/theme/classified.css?pvi6v4");
@import url("//www.simpsoncounty.ms/sites/all/modules/ctools/css/ctools.css?pvi6v4");
@import url("//www.simpsoncounty.ms/sites/all/modules/event_calendar/event_popup/css/event_popup.css?pvi6v4");
@import url("//www.simpsoncounty.ms/sites/all/modules/ctools/css/modal.css?pvi6v4");
@import url("//www.simpsoncounty.ms/sites/all/modules/responsive_menus/styles/responsive_menus_simple/css/responsive_menus_simple.css?pvi6v4");
</style>
<link type="text/css" rel="stylesheet" href="/sites/all/modules/custom/emmerich_notifications/css/style.css" media="all" />
<style type="text/css" media="all">
@import url("//www.simpsoncounty.ms/sites/all/themes/bones/css/normalize.css?pvi6v4");
@import url("//www.simpsoncounty.ms/sites/all/themes/bones/css/formalize.css?pvi6v4");
@import url("//www.simpsoncounty.ms/sites/all/themes/bones/css/grid_12.css?pvi6v4");
@import url("//www.simpsoncounty.ms/sites/all/themes/bones/css/layout.css?pvi6v4");
</style>
<style type="text/css" media="all">
@import url("//www.simpsoncounty.ms/sites/default/files/fontyourface/wysiwyg.css?pvi6v4");
@import url("//www.simpsoncounty.ms/sites/default/files/fontyourface/font.css?pvi6v4");
@import url("//www.simpsoncounty.ms/sites/all/themes/current/css/style4.css?pvi6v4");
@import url("//www.simpsoncounty.ms/sites/all/themes/current/css/responsive.css?pvi6v4");
@import url("//www.simpsoncounty.ms/sites/all/themes/current/css/custom.css?pvi6v4");
</style>
  <script type="text/javascript" src="//www.simpsoncounty.ms/misc/jquery.js?v=1.4.4"></script>
<script type="text/javascript" src="//www.simpsoncounty.ms/misc/jquery-extend-3.4.0.js?v=1.4.4"></script>
<script type="text/javascript" src="//www.simpsoncounty.ms/misc/jquery.once.js?v=1.2"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];
googletag.slots = googletag.slots || {};
//--><!]]>
</script>
<script type="text/javascript" src="//www.googletagservices.com/tag/js/gpt.js"></script>
<script type="text/javascript" src="//www.simpsoncounty.ms/misc/drupal.js?pvi6v4"></script>
<script type="text/javascript" src="//www.simpsoncounty.ms/misc/ui/jquery.ui.core.min.js?v=1.8.7"></script>
<script type="text/javascript" src="//www.simpsoncounty.ms/misc/ui/jquery.ui.widget.min.js?v=1.8.7"></script>
<script type="text/javascript" src="//www.simpsoncounty.ms/misc/ui/jquery.ui.button.min.js?v=1.8.7"></script>
<script type="text/javascript" src="//www.simpsoncounty.ms/misc/ui/jquery.ui.mouse.min.js?v=1.8.7"></script>
<script type="text/javascript" src="//www.simpsoncounty.ms/misc/ui/jquery.ui.draggable.min.js?v=1.8.7"></script>
<script type="text/javascript" src="//www.simpsoncounty.ms/misc/ui/jquery.ui.position.min.js?v=1.8.7"></script>
<script type="text/javascript" src="//www.simpsoncounty.ms/misc/ui/jquery.ui.resizable.min.js?v=1.8.7"></script>
<script type="text/javascript" src="//www.simpsoncounty.ms/misc/ui/jquery.ui.dialog.min.js?v=1.8.7"></script>
<script type="text/javascript" src="//www.simpsoncounty.ms/sites/all/modules/views/js/jquery.ui.dialog.patch.js?v=1.8.7"></script>
<script type="text/javascript" src="//www.simpsoncounty.ms/misc/jquery.cookie.js?v=1.0"></script>
<script type="text/javascript" src="//www.simpsoncounty.ms/misc/jquery.form.js?v=2.52"></script>
<script type="text/javascript" src="//www.simpsoncounty.ms/misc/ajax.js?v=7.67"></script>
<script type="text/javascript" src="//www.simpsoncounty.ms/sites/all/modules/simpleads/simpleads.js?pvi6v4"></script>
<script type="text/javascript" src="//www.simpsoncounty.ms/sites/all/modules/simpleads/modules/simpleads_campaigns/simpleads_campaigns.js?pvi6v4"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
googletag.cmd.push(function() {
  googletag.pubads().enableAsyncRendering();
  googletag.pubads().enableSingleRequest();
  googletag.pubads().collapseEmptyDivs();
});

googletag.enableServices();
//--><!]]>
</script>
<script type="text/javascript" src="//www.simpsoncounty.ms/sites/all/modules/event_calendar/event_popup/js/event_popup.js?pvi6v4"></script>
<script type="text/javascript" src="//www.simpsoncounty.ms/sites/all/modules/event_calendar/event_popup/js/event_popup_validate.js?pvi6v4"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
jQuery(document).ready(function($) { 
    $.expr[':'].regex = function(elem, index, match) {
            var matchParams = match[3].split(','),
            validLabels = /^(data|css):/,
            attr = {
                method: matchParams[0].match(validLabels) ? 
                matchParams[0].split(':')[0] : 'attr',
                property: matchParams.shift().replace(validLabels,'')
            },
            regexFlags = 'ig',
            regex = new RegExp(matchParams.join('').replace(/^\s+|\s+$/g,''), regexFlags);
            return regex.test(jQuery(elem)[attr.method](attr.property));
        }
    });
//--><!]]>
</script>
<script type="text/javascript" src="//www.simpsoncounty.ms/misc/progress.js?v=7.67"></script>
<script type="text/javascript" src="//www.simpsoncounty.ms/sites/all/modules/ctools/js/modal.js?pvi6v4"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
var switchTo5x = true;var useFastShare = 1;
//--><!]]>
</script>
<script type="text/javascript" src="https://ws.sharethis.com/button/buttons.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
if (typeof stLight !== 'undefined') { stLight.options({"publisher":"fc937732-3d58-4754-8720-1d210502838c","version":"5x","doNotCopy":false,"hashAddressBar":true,"doNotHash":false,"onhover":false,"newOrZero":"zero","lang":"en"}); }
//--><!]]>
</script>
<script type="text/javascript" src="//www.simpsoncounty.ms/sites/all/modules/responsive_menus/styles/responsive_menus_simple/js/responsive_menus_simple.js?pvi6v4"></script>
<script type="text/javascript" src="//www.simpsoncounty.ms/sites/all/modules/google_analytics/googleanalytics.js?pvi6v4"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
(function(i,s,o,g,r,a,m){i["GoogleAnalyticsObject"]=r;i[r]=i[r]||function(){(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)})(window,document,"script","//www.google-analytics.com/analytics.js","ga");ga("create", "UA-75225316-11", {"cookieDomain":"auto"});ga("set", "anonymizeIp", true);ga("send", "pageview");
//--><!]]>
</script>
<script type="text/javascript" src="/sites/all/modules/custom/emmerich_notifications/js/script.js"></script>
<script type="text/javascript" src="//www.simpsoncounty.ms/sites/all/modules/fb_likebox/fb_likebox.js?pvi6v4"></script>
<script type="text/javascript" src="//use.edgefonts.net/eb-garamond:n4.js"></script>
<script type="text/javascript" src="//www.simpsoncounty.ms/sites/all/themes/bones/js/jquery.formalize.min.js?pvi6v4"></script>
<script type="text/javascript" src="//www.simpsoncounty.ms/sites/all/themes/bones/js/superfish.js?pvi6v4"></script>
<script type="text/javascript" src="//www.simpsoncounty.ms/sites/all/themes/current/js/scripts.js?pvi6v4"></script>
<script type="text/javascript" src="//www.simpsoncounty.ms/sites/all/themes/bones/js/jquery.easing.1.3.js?pvi6v4"></script>
<script type="text/javascript" src="//www.simpsoncounty.ms/sites/all/themes/bones/js/jquery.equal-height-columns.js?pvi6v4"></script>
<script type="text/javascript" src="//www.simpsoncounty.ms/sites/all/themes/current/js/jquery.mobilemenu.min.js?pvi6v4"></script>
<script type="text/javascript" src="//www.simpsoncounty.ms/sites/all/themes/current/js/jquery.color.js?pvi6v4"></script>
<script type="text/javascript" src="//www.simpsoncounty.ms/sites/all/themes/current/js/jquery-glowing.js?pvi6v4"></script>
<script type="text/javascript">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</script>
  <meta name="viewport" content="width=device-width, initial-scale=1">  
  <!--[if lt IE 9]><script src="http://html5shiv.googlecode.com/svn/trunk/html5.js"></script><![endif]-->
  <link href='https://fonts.googleapis.com/css?family=Paytone+One' rel='stylesheet' type='text/css'>
  <script type="text/javascript" async="async" src="https://widgets.outbrain.com/outbrain.js"></script>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
  (adsbygoogle = window.adsbygoogle || []).push({
    google_ad_client: "ca-pub-8039211595423832",
    enable_page_level_ads: true
  });
</script>

</head>

<body class="html not-front not-logged-in one-sidebar sidebar-second page-node page-node- page-node-5018 node-type-article sidebars-split front-page-slideshow-news primary-election-tuesday">
  <div id="skip-link">
    <a href="#main-content" class="element-invisible element-focusable">Skip to main content</a>
  </div>
    <div id="page">

  <div class="user-menu-wrapper"><div class="user-menu-wrapper-inner container_12">  
    <nav id="user-menu" class="grid_12 clearfix">
        <div class="region region-user-menu">
    <div id="block-system-user-menu" class="block block-system block-menu"><div class="block-inner">

	      <h3 class="title"><span>User menu</span></h3>
     
  <div class="content">
		<ul class="menu"><li class="first last leaf"><a href="/user/login" title=""><span>Login</span></a></li>
</ul>  </div>

</div></div>   </div>
        <div class="region region-search-box">
    <div id="block-search-form" class="block block-search"><div class="block-inner">

	     
  <div class="content">
		<form onsubmit="if(this.search_block_form.value==&#039;Search&#039;){ alert(&#039;Please enter a search&#039;); return false; }" action="/front-page-slideshow-news/primary-election-tuesday" method="post" id="search-block-form" accept-charset="UTF-8"><div><div class="container-inline">
      <h2 class="element-invisible">Search form</h2>
    <div class="form-item form-type-textfield form-item-search-block-form">
  <label class="element-invisible" for="edit-search-block-form--2">Search </label>
 <input title="Enter the terms you wish to search for." onblur="if (this.value == &#039;&#039;) {this.value = &#039;Search&#039;;}" onfocus="if (this.value == &#039;Search&#039;) {this.value = &#039;&#039;;}" type="text" id="edit-search-block-form--2" name="search_block_form" value="" size="15" maxlength="128" class="form-text" />
</div>
<div class="form-actions form-wrapper" id="edit-actions"><input type="submit" id="edit-submit" name="op" value="Search" class="form-submit" /></div><input type="hidden" name="form_build_id" value="form-YmkhY_WUQ98bF_a0YE_VUa3li4pkDSfOnMeSAqRnxbs" />
<input type="hidden" name="form_id" value="search_block_form" />
</div>
</div></form>  </div>

</div></div>   </div>
      <div id="social">
        <ul class="social-links">
          <li><a class="rss" href="/rss.xml"></a></li>
          <li><a class="twitter" href="http://www.twitter.com"></a></li>
          <li><a class="facebook" href="http://www.facebook.com"></a></li>
        </ul>
      </div>         
    </nav>
  </div></div>

  <div class="header-wrapper"><div class="header-wrapper-inner container_12">
    <header class="grid_12 clearfix">
            <div class="logo-slogan">  
        
                  <div class="site-logo">
            <a href="/"><img src="//www.simpsoncounty.ms/sites/default/files/header 2017.jpg" alt="" /></a>
          </div>
        	      
        
        <hgroup>
        
                    
                     
        
        </hgroup> 
  
      </div>

           
    </header>  
    
  </div></div>

      
    <div class="main-menu-wrapper"><div class="main-menu-wrapper-inner container_12">  
      <nav id="main-menu" class="grid_12 clearfix">
          <div class="region region-main-menu">
    <div id="block-system-main-menu" class="block block-system block-menu"><div class="block-inner">

	      <h3 class="title"><span>Main menu</span></h3>
     
  <div class="content">
		<ul class="menu"><li class="first expanded"><a href="/" title="Home"><span>Home</span></a><ul class="menu"><li class="first leaf"><a href="/submit-news"><span>Submit News</span></a></li>
<li class="leaf"><a href="/our-staff" title="Our Staff"><span>Our Staff</span></a></li>
<li class="leaf"><a href="/contact-us" title="Contact Us"><span>Contact Us</span></a></li>
<li class="leaf"><a href="/faqs" title="FAQ&#039;s"><span>FAQ&#039;s</span></a></li>
<li class="leaf"><a href="/about-us"><span>Our History</span></a></li>
<li class="leaf"><a href="/magee-courier-and-simpson-county-news"><span>Subscribe</span></a></li>
<li class="last leaf"><a href="/classified" title=""><span>Classifieds</span></a></li>
</ul></li>
<li class="leaf"><a href="/e-edition-front"><span>E-Edition</span></a></li>
<li class="expanded"><a href="/news" title=""><span>News</span></a><ul class="menu"><li class="first leaf"><a href="/breaking-news" title=""><span>Breaking News</span></a></li>
<li class="leaf"><a href="/crime" title=""><span>Crime</span></a></li>
<li class="leaf"><a href="/documents" title=""><span>Documents</span></a></li>
<li class="leaf"><a href="/features" title=""><span>Features</span></a></li>
<li class="leaf"><a href="/public-notices" title=""><span>Public Notices</span></a></li>
<li class="leaf"><a href="/sports" title=""><span>Sports</span></a></li>
<li class="leaf"><a href="/politics" title=""><span>Politics</span></a></li>
<li class="last leaf"><a href="/most-read"><span>Most Read</span></a></li>
</ul></li>
<li class="expanded"><a href="/opinion" title=""><span>Opinion</span></a><ul class="menu"><li class="first leaf"><a href="/columns"><span>Columns</span></a></li>
<li class="leaf"><a href="/comments"><span>Comments</span></a></li>
<li class="leaf"><a href="/editorials"><span>Editorials</span></a></li>
<li class="last leaf"><a href="/letters"><span>Letters</span></a></li>
</ul></li>
<li class="expanded"><a href="/social" title=""><span>Social</span></a><ul class="menu"><li class="first leaf"><a href="/birthdays-anniversaries" title=""><span>Birthdays/Anniversaries</span></a></li>
<li class="leaf"><a href="/events" title=""><span>Events</span></a></li>
<li class="leaf"><a href="/obituaries" title=""><span>Obituaries</span></a></li>
<li class="leaf"><a href="/schools" title=""><span>Schools</span></a></li>
<li class="last leaf"><a href="/weddingsengagements"><span>Weddings/Engagements</span></a></li>
</ul></li>
<li class="expanded"><a href="/newspaper-rates" title=""><span>Advertising</span></a><ul class="menu"><li class="first leaf"><a href="/newspaper-rates"><span>Ad Rates</span></a></li>
<li class="last leaf"><a href="http://132.148.129.183/~magee/classified" title=""><span>Classifieds</span></a></li>
</ul></li>
<li class="leaf"><a href="/magee-courier-and-simpson-county-news-archives"><span>Archives</span></a></li>
<li class="last leaf"><a href="/events"><span>Columns</span></a></li>
</ul>  </div>

</div></div>   </div>
      </nav>
    </div></div> 
      
  
  <div class="main-menu-second-level-wrapper clearfix"><div class="main-menu-second-level-wrapper-inner container_12">  
    <nav id="main-menu-second-level" class="grid_12">
            
    </nav>
  </div></div> 
  
<!-- Main Content -->  
  <div class="main-content-wrapper"><div class="main-content-wrapper-inner container_12">
    <section id="main-content" class="clearfix"> 	   

          
    
      <div class="main">
        <div class="main-inner  grid_6">

                
	      
        
                                          
          <div class="main-inner-wrp">
            <div class="region region-content-top">
    <div id="block-dfp-mgc-top-leaderboard" class="block block-dfp adServeMargin"><div class="block-inner">

	     
  <div class="content">
		<div id="dfp-ad-mgc_top_leaderboard-wrapper" class="dfp-tag-wrapper">
<a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/595218311/mgc_top_leaderboard&sz=600x500&c=66894">
  <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/595218311/mgc_top_leaderboard&sz=600x500&c=66894">
</a>
</div>  </div>

</div></div>   </div>
                                          <div class="region region-content">
    <div id="block-system-main" class="block block-system"><div class="block-inner">

	     
  <div class="content">
		<article id="node-5018" class="node node-article node-promoted last clearfix">



  
    <div class="field-image">

      <div class="field field-name-field-image field-type-image field-label-hidden"><div class="field-items"><div class="field-item even"><img src="//www.simpsoncounty.ms/sites/default/files/styles/large/public/field/image/election machine.jpg?itok=ocA-ypCr" width="576" height="384" alt="" /></div></div></div>
    </div>

  


  


  <div class="node-content-wrapper">



    


      


      
       <h1 class="title">Primary Election Tuesday</h1>

      


    


    By <A HREF="/AUTHOR-CONTENT/278"><SPAN>MARLAN JONES</SPAN></A>,


    
        <ul class="links inline"><li class="statistics_counter first last"><span>268 reads</span></li>
</ul>
    


    
      <div class="submitted">

            <span class="date">Tue, 07/30/2019 - 3:09pm</span>

      </div>

    


    <div class="content">

    <div class="field field-name-body field-type-text-with-summary field-label-hidden"><div class="field-items"><div class="field-item even"> <p>***Editors Note*** We made an error in the Circuit Clerk's race. Steve Womack did withdraw from the race. He will not be on the ballot Tuesday. In the Republican race it will be between Keilah Berry and Witt Fortenberry.</p>
<p>Primary elections for partisan candidates will be held on Tuesday, August 6, with necessary runoff elections to follow on August 27.</p>
<p>The General Election is scheduled for November 5, and runoffs will be held on November 26.</p>
<p>Offices to will be voted on this year include governor, lieutenant governor, secretary of state, attorney general, commissioner of agriculture and commerce, public service commissioner, transportation commissioner, district attorney, senate, representatives, sheriff, chancery clerk, circuit clerk, tax assessor, justice court judge, supervisor positions, election commissioners, and constables.</p>
<p>Simpson County voter participation has been on the rise recently, and the trend will likely continue with the increased number of offices up for grabs this year.  Of the 15 local races being featured on the ballot, only five races will advance to the November without a clear winner. Many will be decided in the August primaries.</p>
<p>Three candidates qualified for the office of Chancery Clerk, Tommy Joe Harvey (R), Bill Gerald (I), and Willie Ree McDonald (D). Because the three candidates have no opposition in their own parites in the upcoming primaries, they will face each other in the November elections instead.</p>
<p>The Circuit Clerk’s race produced four candidates, Steve Womack (R), Terrence Norwood (D), Keilah Berry (R), and Witt Fortenberry (R). Berry and Womack were previously pitted against each other in a close race that saw Womack emerge as the winner. Newcomers Terrence Norwood and Witt Fortenberry have made strong efforts in vying for the office. Norwood faces no opposition in the Democratic Primary and will face the winner out of Berry, Fortenberry, and Womack in the Republican Primary.</p><div class="ad">
        <div class="left"><div id="block-dfp-537847d8b9268586160749bbb4f14fb3" class="block block-dfp adServeMargin"><div class="block-inner">

	     
  <div class="content">
		<div id="dfp-ad-mgc_top_left_in_story_medium_rectangle-wrapper" class="dfp-tag-wrapper">
<a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/595218311/mgc_top_left_in-story_medium_rectangle&sz=600x500&c=51004">
  <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/595218311/mgc_top_left_in-story_medium_rectangle&sz=600x500&c=51004">
</a>
</div>  </div>

</div></div> </div>
        </div>
<p>Constable Post 1 will be decided between two Republican candidates Jamie Freeman and Randall Coleman. Constable Post 2 will also be decided between two Republican candidates Dusty Drennan and Christopher Jones. These two candidates recently participated in an election last November that was decided by one percent. Drennan received 2,116 votes (49%) and Jones received 2,196 votes (50%).</p>
<p>Coroner Terry Tutor and Election Commissioner Donna Magee will retain their offices after being unopposed.</p>
<p>Justice Court Judge Post 1 will be decided between Allen Floyd and Ted Blakeney in the Republican Primary. Justice Court Judge Post 2 race will be between Charles Savell and Joey Womack. Savell recently took over the position after the election last November.  Joey Womack has served as the assistant police chief of Magee for several years. The two will face each other in Republican primary to determine the winner.</p>
<p>The Sheriff’s office has produced three candidates. Paul Mullins qualified for the Republican Party and Cedrick Allbritton and Darrell Walker qualified for the Democratic Party. The winner of each primary will face each other in the November election.</p>
<p>The Simpson County Board of Supervisors may have new faces following this election season. Supervisor of District 1 office produced three candidates. Incumbent Curtis Skiffer will face G. Mitchell Chatman, and Wayne Stubbs in the Democratic Primary.  Supervisor of District 2 will be decided in the Republican Primary. Allen Maddox, Danny Craft, and Terry “Bubba” Brannan Jr all qualified for the position.</p>
<p>The incumbent of Supervisor District 3 Brian Kennedy is running unopposed and will retain his position. Supervisor races for District 4 and District 5 will be decided in November. In District 4 Hardy Williams qualified as the lone democratic candidate. Donny Welch and Gerald Brown will face-off in the Republican primary, and the winner will face Williams in November.</p>
<p>Supervisor District 5 seems to be the most sought after position in the county, producing 6 candidates. Larry Barnes and Fredrick Alexander qualified as Democrats. Jason Rowan McCoy, Randy Moore, Dean Barnard, and Mickey Welch qualified as Republicans.</p><div class="ad">
        <div class="right"><div id="block-dfp-3fe50c3e00a178ac2b2fa864749e4900" class="block block-dfp"><div class="block-inner">

	     
  <div class="content">
		<div id="dfp-ad-mgc_top_right_in_story_medium_rectangle-wrapper" class="dfp-tag-wrapper">
<a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/595218311/mgc_top_right_in-story_medium_rectangle&sz=600x500&c=41092">
  <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/595218311/mgc_top_right_in-story_medium_rectangle&sz=600x500&c=41092">
</a>
</div>  </div>

</div></div> </div>
        </div>
<p>Jamie Reed Brewer will be the new Tax Assessor for Simpson County as she runs unopposed. She will be taking over the position from Charles Baldwin who served in the role for over 20 years.</p>
<p>Again primary elections will be held on August 6 with necessary runoff elections to follow on August 27.</p>
 </div></div></div><div class="item-list"><ul class="pager-for-content-type flippy"><li class="pager-previous prev first"><a href="/front-page-slideshow-news/citizens-express-concerns-over-schools#node-5017" class="prev"><span>‹ Previous</span></a></li>
<li class="pager-next next last"><a href="/front-page-slideshow-news/women%E2%80%99s-hope-host-open-house-fall-session#node-5019" class="next"><span>Next ›</span></a></li>
</ul></div>
    </div>







    
      <nav class="taxonomy"><div class="taxonomy-inner clearfix">

        
      </div></nav>

    


  
      <nav class="taxonomy"><div class="taxonomy-inner clearfix">

        
      </div></nav>

    


 






  </div>





</article>




  </div>

</div></div> <div id="block-sharethis-sharethis-block" class="block block-sharethis"><div class="block-inner">

	     
  <div class="content">
		<div class="sharethis-wrapper"><span st_url="https://www.simpsoncounty.ms/front-page-slideshow-news/primary-election-tuesday" st_title="Primary Election Tuesday" class="st_facebook&amp;amp;quot_button" displayText="facebook&amp;amp;amp;quot"></span>
<span st_url="https://www.simpsoncounty.ms/front-page-slideshow-news/primary-election-tuesday" st_title="Primary Election Tuesday" class="st_twitter&amp;amp;quot_button" displayText="twitter&amp;amp;amp;quot"></span>
<span st_url="https://www.simpsoncounty.ms/front-page-slideshow-news/primary-election-tuesday" st_title="Primary Election Tuesday" class="st_pinterest&amp;amp;quot_button" displayText="pinterest&amp;amp;amp;quot"></span>
<span st_url="https://www.simpsoncounty.ms/front-page-slideshow-news/primary-election-tuesday" st_title="Primary Election Tuesday" class="st_tumblr&amp;amp;quot_button" displayText="tumblr&amp;amp;amp;quot"></span>
<span st_url="https://www.simpsoncounty.ms/front-page-slideshow-news/primary-election-tuesday" st_title="Primary Election Tuesday" class="st_email&amp;amp;quot_button" displayText="email&amp;amp;amp;quot"></span>
<span st_url="https://www.simpsoncounty.ms/front-page-slideshow-news/primary-election-tuesday" st_title="Primary Election Tuesday" class="st_fblike_button" displayText="fblike"></span>
<span st_url="https://www.simpsoncounty.ms/front-page-slideshow-news/primary-election-tuesday" st_title="Primary Election Tuesday" class="st_twitterfollow_button" displayText="twitterfollow" st_username="https://twitter.com/MageeCourier"></span>
</div>  </div>

</div></div> <div id="block-facebook-comments-box-facebook-comments-box" class="block block-facebook-comments-box"><div class="block-inner">

	     
  <div class="content">
		<div class="facebook-comments-box"><div id="fb-root"></div><script src="http://connect.facebook.net/en_US/all.js#xfbml=1"></script><fb:comments href="https://www.simpsoncounty.ms/front-page-slideshow-news/primary-election-tuesday"  num_posts="10"  width="580"  colorscheme="light" ></fb:comments></div>  </div>

</div></div>   </div>
  
                  
                              </div> 
        </div> 
                <aside class="sidebar second-sidebar grid_6">
          <div class="sidebar-wrp">
              <div class="region region-second-ad">
    <div id="block-block-46" class="block block-block sign-up-for-emmerich-notifications"><div class="block-inner">

	      <h3 class="title"><span>Sign Up for Notifications of Local Breaking News</span></h3>
     
  <div class="content">
		<p><a class="ctools-use-moda start" href="/emmerich/subscribe/email/js">Start E-mail Notifications</a></p>
<p><a class="ctools-use-modal stop" href="/emmerich/unsubscribe/email-popup/js">Stop E-mail Notifications</a></p>
<p><a class="ctools-use-modal start" href="/emmerich/subscribe/mobile/js">Start Mobile Notifications</a></p>
<p><a class="ctools-use-modal stop" href="/emmerich/unsubscribe/mobile/js">Stop Mobile Notifications</a></p>  </div>

</div></div> <div id="block-block-44" class="block block-block adServerMargin thin"><div class="block-inner">

	     
  <div class="content">
		 <p style="text-align: center;"> </p>
<p style="text-align: center;"><a href="https://simpsoncounty.ms/e-edition-front"><img alt="" class="media-image" height="576" style="width: 300px; height: 400px;" width="432" src="//www.simpsoncounty.ms/sites/default/files/styles/large/public/e edition.jpg?itok=mZILQvsN" /></a></p>
   </div>

</div></div> <div id="block-dfp-baec784b2e7c691e068ee141cc3cdf39" class="block block-dfp adServeMargin"><div class="block-inner">

	     
  <div class="content">
		<div id="dfp-ad-mgc_middle_2_skyscraper_medium_rectangle-wrapper" class="dfp-tag-wrapper">
<a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/595218311/mgc_middle_2_skyscraper_medium_rectangle&sz=600x500&c=54085">
  <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/595218311/mgc_middle_2_skyscraper_medium_rectangle&sz=600x500&c=54085">
</a>
</div>  </div>

</div></div> <div id="block-fb-likebox-0" class="block block-fb-likebox adServeMargin"><div class="block-inner">

	     
  <div class="content">
		<div class="fb-page" data-href="https://www.facebook.com/simpsonpublishing/" data-width="300" data-height="500" data-tabs="timeline" data-hide-cover="0" data-show-facepile="1" data-hide-cta="0" data-small-header="0" data-adapt-container-width="1"><div class="fb-xfbml-parse-ignore"><blockquote cite="https://www.facebook.com/simpsonpublishing/"><a href="https://www.facebook.com/simpsonpublishing/"><span>Like us on Facebook</span></a></blockquote></div></div>  </div>

</div></div> <div id="block-dfp-96186e5278b5d31b061bc28f71c87bcf" class="block block-dfp adServeMargin hideFeed"><div class="block-inner">

	     
  <div class="content">
		<div id="dfp-ad-mgc_middle_3_skyscraper_medium_rectangle-wrapper" class="dfp-tag-wrapper">
<a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/595218311/mgc_middle_3_skyscraper_medium_rectangle&sz=600x500&c=90628">
  <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/595218311/mgc_middle_3_skyscraper_medium_rectangle&sz=600x500&c=90628">
</a>
</div>  </div>

</div></div> <div id="block-dfp-62300d51bb14de309cc7be5cec37a795" class="block block-dfp adServeMargin hideFeed"><div class="block-inner">

	     
  <div class="content">
		<div id="dfp-ad-mgc_middle_4_skyscraper_medium_rectangle-wrapper" class="dfp-tag-wrapper">
<a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/595218311/mgc_middle_4_skyscraper_medium_rectangle&sz=600x500&c=23012">
  <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/595218311/mgc_middle_4_skyscraper_medium_rectangle&sz=600x500&c=23012">
</a>
</div>  </div>

</div></div> <div id="block-block-43" class="block block-block adServeMargin thin"><div class="block-inner">

	     
  <div class="content">
		 <p style="text-align: center;"><a href="https://cdn.flipsnack.com/widget/v2/widget.html?hash=fti2vsyak&amp;bgcolor=EEEEEE&amp;t=1512666246"><img alt="" class="media-image" style="width: 300px; height: 400px;" src="//www.simpsoncounty.ms/sites/default/files/styles/large/public/Magazine.jpg?itok=eloF3ybH" width="432" height="576" /></a></p>
   </div>

</div></div> <div id="block-dfp-1389e1391503793d54c138ff2b817f2e" class="block block-dfp adServeMargin hideFeed"><div class="block-inner">

	     
  <div class="content">
		<div id="dfp-ad-mgc_middle_5_skyscraper_medium_rectangle-wrapper" class="dfp-tag-wrapper">
<a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/595218311/mgc_middle_5_skyscraper_medium_rectangle&sz=600x500&c=79314">
  <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/595218311/mgc_middle_5_skyscraper_medium_rectangle&sz=600x500&c=79314">
</a>
</div>  </div>

</div></div> <div id="block-block-45" class="block block-block adServerMargin thin"><div class="block-inner">

	     
  <div class="content">
		 <p style="text-align: center;"><a href="https://simpsoncounty.ms/most-read"><img alt="" class="media-image" height="768" style="width: 300px; height: 400px;" width="576" src="//www.simpsoncounty.ms/sites/default/files/styles/large/public/Most Read Stories.jpg?itok=v7MJPs2n" /></a></p>
   </div>

</div></div> <div id="block-dfp-f626bed6b7e1593bd6ad3f1ec8aae68e" class="block block-dfp adServeMargin hideFeed"><div class="block-inner">

	     
  <div class="content">
		<div id="dfp-ad-mgc_middle_6_skyscraper_medium_rectangle-wrapper" class="dfp-tag-wrapper">
<a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/595218311/mgc_middle_6_skyscraper_medium_rectangle&sz=600x500&c=84670">
  <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/595218311/mgc_middle_6_skyscraper_medium_rectangle&sz=600x500&c=84670">
</a>
</div>  </div>

</div></div>   </div>
              <div class="region region-sidebar-second">
    <div id="block-dfp-8124943f113c9659561123cef8b2d444" class="block block-dfp adServeMargin"><div class="block-inner">

	     
  <div class="content">
		<div id="dfp-ad-mgc_middle_1_skyscraper_medium_rectangle-wrapper" class="dfp-tag-wrapper">
<a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/595218311/mgc_middle_1_skyscraper_medium_rectangle&sz=600x500&c=80488">
  <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/595218311/mgc_middle_1_skyscraper_medium_rectangle&sz=600x500&c=80488">
</a>
</div>  </div>

</div></div> <div id="block-block-34" class="block block-block adServeMargin"><div class="block-inner">

	     
  <div class="content">
		<!-- Medium Rectangle [async] -->
<script type="text/javascript">if (!window.AdButler){(function(){var s = document.createElement("script"); s.async = true; s.type = "text/javascript";s.src = 'https://servedbyadbutler.com/app.js';var n = document.getElementsByTagName("script")[0]; n.parentNode.insertBefore(s, n);}());}</script>
<script type="text/javascript">
var AdButler = AdButler || {}; AdButler.ads = AdButler.ads || [];
var abkw = window.abkw || '';
var plc309765 = window.plc309765 || 0;
document.write('<'+'div id="placement_309765_'+plc309765+'"></'+'div>');
AdButler.ads.push({handler: function(opt){ AdButler.register(171437, 309765, [300,250], 'placement_309765_'+opt.place, opt); }, opt: { place: plc309765++, keywords: abkw, domain: 'servedbyadbutler.com', click:'CLICK_MACRO_PLACEHOLDER' }});
</script>
  </div>

</div></div>   </div>
  
          </div>                
        </aside>
             
      </div>            
  
    </section>
  </div></div>
  
    
    <div class="preface-wrapper"><div class="preface-wrapper-inner container_12">  
      <section id="preface" class="clearfix">
        <div class="grid_6">  <div class="region region-preface-1">
    <div id="block-dfp-3165677677f8a73012bcd08e3e0c50d9" class="block block-dfp adServeMargin hideFeed"><div class="block-inner">

	     
  <div class="content">
		<div id="dfp-ad-mgc_top_left_widget_medium_rectangle-wrapper" class="dfp-tag-wrapper">
<a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/595218311/mgc_top_left_widget_medium_rectangle&sz=600x500&c=99526">
  <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/595218311/mgc_top_left_widget_medium_rectangle&sz=600x500&c=99526">
</a>
</div>  </div>

</div></div> <div id="block-views-breaking-news-block" class="block block-views"><div class="block-inner">

	      <h3 class="title"><span>Breaking News</span></h3>
     
  <div class="content">
		<div class="view view-breaking-news view-id-breaking_news view-display-id-block view-dom-id-f6d46844d01c574f5b1e1ce3a622ca0b">
        
  
  
      <div class="view-content">
        <div class="views-row views-row-1 views-row-odd views-row-first views-row-last">
      
  <div class="views-field views-field-field-image">        <div class="field-content"><a href="/front-page-slideshow-news-breaking-news-crime/search-warrant-leads-drug-arrests"><span><img src="//www.simpsoncounty.ms/sites/default/files/styles/thumbnail/public/field/image/Dope.jpg?itok=_QYZaSmC" width="100" height="65" alt="" /></span></a></div>  </div>  
  <div class="views-field views-field-title">        <span class="field-content"><a href="/front-page-slideshow-news-breaking-news-crime/search-warrant-leads-drug-arrests"><span>Search Warrant Leads to Drug Arrests</span></a></span>  </div>  
  <div class="views-field views-field-body">        <span class="field-content"> Early Wednesday morning July 31st 2019, Simpson County Sheriff’s deputies and officers with the... <a href="/front-page-slideshow-news-breaking-news-crime/search-warrant-leads-drug-arrests" class="views-more-link"><span>READ MORE</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
      </div>
  
  
      <div class="attachment attachment-after">
      <div class="view view-breaking-news view-id-breaking_news view-display-id-attachment_1">
        
  
  
      <div class="view-content">
        <div class="views-row views-row-1 views-row-odd views-row-first">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/front-page-slideshow-news-breaking-news/health-officials-urge-mississippi-residents-prepare-tropical"><span>Health Officials Urge Mississippi Residents to Prepare Before Tropical Storm Barry</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
    <div class="views-row views-row-2 views-row-even">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/front-page-slideshow-news-breaking-news/priorityone-bank-number-1-state"><span>PriorityOne Bank is number 1 in state</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
    <div class="views-row views-row-3 views-row-odd">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/front-page-slideshow-news-breaking-news-crime/mbi-investigates-officer-involved-shooting"><span>MBI Investigates Officer Involved Shooting</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
    <div class="views-row views-row-4 views-row-even">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/front-page-slideshow-news-breaking-news/missing-person-found"><span>Missing Person Found</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
    <div class="views-row views-row-5 views-row-odd views-row-last">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/front-page-slideshow-news-breaking-news-schools/early-dismissal"><span>EARLY DISMISSAL</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
      </div>
  
  
  
  
  
  
</div>    </div>
  
  
  
  
</div>  </div>

</div></div> <div id="block-dfp-241a831f9037e191ca2612ac4a10538c" class="block block-dfp adServeMargin hideFeed"><div class="block-inner">

	     
  <div class="content">
		<div id="dfp-ad-mgc_middle_left_widget_medium_rectangle-wrapper" class="dfp-tag-wrapper">
<a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/595218311/mgc_middle_left_widget_medium_rectangle&sz=600x500&c=87960">
  <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/595218311/mgc_middle_left_widget_medium_rectangle&sz=600x500&c=87960">
</a>
</div>  </div>

</div></div> <div id="block-views-obituaries-block" class="block block-views"><div class="block-inner">

	      <h3 class="title"><span>Obituaries</span></h3>
     
  <div class="content">
		<div class="view view-obituaries view-id-obituaries view-display-id-block view-dom-id-f17d84f8f40e1daf6f616cc7f4994215">
        
  
  
      <div class="view-content">
        <div class="views-row views-row-1 views-row-odd views-row-first views-row-last">
      
  <div class="views-field views-field-field-image">        <div class="field-content"></div>  </div>  
  <div class="views-field views-field-title">        <span class="field-content"><a href="/obituaries/everett-eddie-pearson"><span>Everett Eddie Pearson</span></a></span>  </div>  
  <div class="views-field views-field-body">        <span class="field-content"> Everett Eddie Pearson, 83, of Coldwater, Miss., died at Baptist Desoto Hospital in Southaven, Miss.</span>  </div><hr style="margin-bottom: 20px;">    
  </div>
      </div>
  
  
      <div class="attachment attachment-after">
      <div class="view view-obituaries view-id-obituaries view-display-id-attachment_1">
        
  
  
      <div class="view-content">
        <div class="views-row views-row-1 views-row-odd views-row-first">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/obituaries/thomas-c-taylor"><span>Thomas C. Taylor</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
    <div class="views-row views-row-2 views-row-even">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/obituaries/ernestine-m-allen"><span>Ernestine M. Allen</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
    <div class="views-row views-row-3 views-row-odd">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/obituaries/hilmon-bynum"><span>Hilmon Bynum</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
    <div class="views-row views-row-4 views-row-even">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/obituaries/dora-m-wilson"><span>Dora M. Wilson</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
    <div class="views-row views-row-5 views-row-odd views-row-last">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/obituaries/paul-b-thompson"><span>Paul B. Thompson</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
      </div>
  
  
  
  
  
  
</div>    </div>
  
  
  
  
</div>  </div>

</div></div> <div id="block-dfp-992a6b52100787303f44ee4778742d86" class="block block-dfp adServeMargin hideFeed"><div class="block-inner">

	     
  <div class="content">
		<div id="dfp-ad-mgc_bottom_left_widget_medium_rectangle-wrapper" class="dfp-tag-wrapper">
<a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/595218311/mgc_bottom_left_widget_medium_rectangle&sz=600x500&c=74449">
  <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/595218311/mgc_bottom_left_widget_medium_rectangle&sz=600x500&c=74449">
</a>
</div>  </div>

</div></div> <div id="block-views-arts-top-stories-block" class="block block-views"><div class="block-inner">

	      <h3 class="title"><span>Social</span></h3>
     
  <div class="content">
		<div class="view view-arts-top-stories view-id-arts_top_stories view-display-id-block view-dom-id-c6c1602b1e306eb824a6bc3360fbbd64">
        
  
  
      <div class="view-content">
        <div class="views-row views-row-1 views-row-odd views-row-first views-row-last">
      
  <div class="views-field views-field-field-image">        <div class="field-content"><a href="/community-calendar/community-calendar-8-1-19"><span><img src="//www.simpsoncounty.ms/sites/default/files/styles/thumbnail/public/field/image/Community-Calendar_75.jpg?itok=VYpS_3qs" width="100" height="56" alt="" /></span></a></div>  </div>  
  <div class="views-field views-field-title">        <span class="field-content"><a href="/community-calendar/community-calendar-8-1-19"><span>Community Calendar 8-1-19</span></a></span>  </div>  
  <div class="views-field views-field-body">        <div class="field-content"> August  1
The Republican Women of Simpson County will meet Thursday, August 1, in the E911 Building in Mendenhall at 11 a.m. Guests are welcome. For info call 601-853-2433.</div>  </div><hr style="margin-bottom: 20px;">    
  </div>
      </div>
  
  
      <div class="attachment attachment-after">
      <div class="view view-arts-top-stories view-id-arts_top_stories view-display-id-attachment_1">
        
  
  
      <div class="view-content">
        <div class="views-row views-row-1 views-row-odd views-row-first">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/community-calendar/community-calendar-7-25-2019"><span>Community Calendar 7-25-2019</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
    <div class="views-row views-row-2 views-row-even">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/community-calendar/community-calendar-7-18-2019"><span>Community Calendar 7-18-2019</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
    <div class="views-row views-row-3 views-row-odd">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/community-calendar/community-calendar-7-11-19"><span>Community Calendar 7-11-19</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
    <div class="views-row views-row-4 views-row-even">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/community-calendar/community-calendar-7-4-2019"><span>Community Calendar 7-4-2019</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
    <div class="views-row views-row-5 views-row-odd views-row-last">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/community-calendar/community-calendar-6-27-2019"><span>Community Calendar 6-27-2019</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
      </div>
  
  
  
  
  
  
</div>    </div>
  
  
  
  
</div>  </div>

</div></div> <div id="block-dfp-b2a1fa513ba0389ab8764916bb362bac" class="block block-dfp adServeMargin hideFeed"><div class="block-inner">

	     
  <div class="content">
		<div id="dfp-ad-mgc_top_right_widget_medium_rectangle-wrapper" class="dfp-tag-wrapper">
<a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/595218311/mgc_top_right_widget_medium_rectangle&sz=600x500&c=50110">
  <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/595218311/mgc_top_right_widget_medium_rectangle&sz=600x500&c=50110">
</a>
</div>  </div>

</div></div> <div id="block-dfp-e8b675619ba5d51a4c7d8a88a758dd4a" class="block block-dfp adServeMargin hideFeed"><div class="block-inner">

	     
  <div class="content">
		<div id="dfp-ad-mgc_bottom_right_widget_medium_rectangle-wrapper" class="dfp-tag-wrapper">
<a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/595218311/mgc_bottom_right_widget_medium_rectangle&sz=600x500&c=19006">
  <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/595218311/mgc_bottom_right_widget_medium_rectangle&sz=600x500&c=19006">
</a>
</div>  </div>

</div></div>   </div>
</div>
        <div class="grid_6">  <div class="region region-preface-2">
    <div id="block-dfp-e17d7b57a931f1b2bd600db6dbafd4a6" class="block block-dfp adServeMargin hideFeed"><div class="block-inner">

	     
  <div class="content">
		<div id="dfp-ad-mgc_top_middle_widget_medium_rectangle-wrapper" class="dfp-tag-wrapper">
<a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/595218311/mgc_top_middle_widget_medium_rectangle&sz=600x500&c=88841">
  <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/595218311/mgc_top_middle_widget_medium_rectangle&sz=600x500&c=88841">
</a>
</div>  </div>

</div></div> <div id="block-views-business-top-stories-block" class="block block-views"><div class="block-inner">

	      <h3 class="title"><span>Opinion:</span></h3>
     
  <div class="content">
		<div class="view view-business-top-stories view-id-business_top_stories view-display-id-block view-dom-id-6d6e9da28f525ff8bce8925f4c5dd21a">
        
  
  
      <div class="view-content">
        <div class="views-row views-row-1 views-row-odd views-row-first views-row-last">
      
  <div class="views-field views-field-field-image">        <div class="field-content"></div>  </div>  
  <div class="views-field views-field-title">        <span class="field-content"><a href="/columns/two-murder-cases-involving-ole-miss-students-are-very-similar"><span>Two murder cases involving Ole Miss students are very similar</span></a></span>  </div>  
  <div class="views-field views-field-body">        <span class="field-content"> The July murder of a pretty Ole Miss coed is eerily similar to one that occurred about 33 years... <a href="/columns/two-murder-cases-involving-ole-miss-students-are-very-similar" class="views-more-link"><span>READ MORE</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
      </div>
  
  
      <div class="attachment attachment-after">
      <div class="view view-business-top-stories view-id-business_top_stories view-display-id-attachment_1">
        
  
  
      <div class="view-content">
        <div class="views-row views-row-1 views-row-odd views-row-first">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/editorials/according-mayor-millage-should-remain-same"><span>According to mayor, millage should remain the same</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
    <div class="views-row views-row-2 views-row-even">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/columns/%E2%80%9Cstupid-stupid-does%E2%80%9D"><span>“Stupid is as stupid does”</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
    <div class="views-row views-row-3 views-row-odd">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/editorials/our-voting-system-vulnerable"><span>Our voting system is vulnerable </span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
    <div class="views-row views-row-4 views-row-even">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/editorials/there-so-much-going-and-so-little-time"><span>There is so much going on and so little time</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
    <div class="views-row views-row-5 views-row-odd views-row-last">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/columns/eleven-hours-plenty-time-driving"><span>Eleven hours is plenty of time driving</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
      </div>
  
  
  
  
  
  
</div>    </div>
  
  
  
  
</div>  </div>

</div></div> <div id="block-dfp-08c1a33353efded70b049323bd68844d" class="block block-dfp adServeMargin hideFeed"><div class="block-inner">

	     
  <div class="content">
		<div id="dfp-ad-mgc_middle_middle_widget_medium_rectangle-wrapper" class="dfp-tag-wrapper">
<a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/595218311/mgc_middle_middle_widget_medium_rectangle&sz=600x500&c=19968">
  <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/595218311/mgc_middle_middle_widget_medium_rectangle&sz=600x500&c=19968">
</a>
</div>  </div>

</div></div> <div id="block-views-weddings-block" class="block block-views"><div class="block-inner">

	      <h3 class="title"><span>Weddings &amp; Engagements</span></h3>
     
  <div class="content">
		<div class="view view-weddings view-id-weddings view-display-id-block view-dom-id-083300c489b7847a3ff3e3b256e630f9">
        
  
  
      <div class="view-content">
        <div class="views-row views-row-1 views-row-odd views-row-first views-row-last">
      
  <div class="views-field views-field-field-image">        <div class="field-content"><a href="/weddings/stewart-and-warren-wed-march-30"><span><img src="//www.simpsoncounty.ms/sites/default/files/styles/thumbnail/public/field/image/3.jpg?itok=YN9nQJCQ" width="100" height="63" alt="" /></span></a></div>  </div>  
  <div class="views-field views-field-title">        <span class="field-content"><a href="/weddings/stewart-and-warren-wed-march-30"><span>Stewart and Warren to wed March 30</span></a></span>  </div>  
  <div class="views-field views-field-body">        <span class="field-content"> Ms. Sheila Stewart and her late husband, Tommy Stewart, of Harrisville are pleased to announce the... <a href="/weddings/stewart-and-warren-wed-march-30" class="views-more-link"><span>READ MORE</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
      </div>
  
  
      <div class="attachment attachment-after">
      <div class="view view-weddings view-id-weddings view-display-id-attachment_1">
        
  
  
      <div class="view-content">
        <div class="views-row views-row-1 views-row-odd views-row-first">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/weddings/garrity-jones-wed-feb-2"><span>Garrity, Jones to wed Feb. 2</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
    <div class="views-row views-row-2 views-row-even">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/weddings/jones-and-dupre%E2%80%99-wed-june-16"><span>Jones and Dupre’ to wed June 16</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
    <div class="views-row views-row-3 views-row-odd">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/weddings/arender-and-mcintyre-wed"><span>Arender and McIntyre to wed</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
    <div class="views-row views-row-4 views-row-even">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/weddings/banis-fewell-unite-june-2"><span>Banis, Fewell to unite June 2</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
    <div class="views-row views-row-5 views-row-odd views-row-last">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/weddings/smith-and-sanford-wed"><span>Smith and Sanford to wed</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
      </div>
  
  
  
  
  
  
</div>    </div>
  
  
  
  
</div>  </div>

</div></div> <div id="block-dfp-e1d613de5741d6e0070e4374340f611f" class="block block-dfp adServeMargin hideFeed"><div class="block-inner">

	     
  <div class="content">
		<div id="dfp-ad-mgc_bottom_middle_widget_medium_rectangle-wrapper" class="dfp-tag-wrapper">
<a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/595218311/mgc_bottom_middle_widget_medium_rectangle&sz=600x500&c=93083">
  <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/595218311/mgc_bottom_middle_widget_medium_rectangle&sz=600x500&c=93083">
</a>
</div>  </div>

</div></div> <div id="block-statistics-popular" class="block block-statistics"><div class="block-inner">

	      <h3 class="title"><span>Popular content</span></h3>
     
  <div class="content">
		<div class="item-list"><h3>Today's:</h3><ul><li class="first"><a href="/news"><span>News</span></a></li>
<li><a href="/most-read"><span>Most Read</span></a></li>
<li><a href="/contact-us"><span>Contact Us!</span></a></li>
<li><a href="/front-page-slideshow-news-breaking-news-crime/search-warrant-leads-drug-arrests"><span>Search Warrant Leads to Drug Arrests</span></a></li>
<li class="last"><a href="/obituaries/shellye-stanley-mccarty"><span>Shellye Stanley McCarty</span></a></li>
</ul></div><br />  </div>

</div></div> <div id="block-dfp-737317e61abb4dd9f1111abda8cd04c6" class="block block-dfp adServeMargin hideFeed"><div class="block-inner">

	     
  <div class="content">
		<div id="dfp-ad-mgc_middle_right_widget_medium_rectangle-wrapper" class="dfp-tag-wrapper">
<a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/595218311/mgc_middle_right_widget_medium_rectangle&sz=600x500&c=31209">
  <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/595218311/mgc_middle_right_widget_medium_rectangle&sz=600x500&c=31209">
</a>
</div>  </div>

</div></div>   </div>
</div>
        <div class="grid_0"></div>
        <div class="grid_0"></div>
      </section>
        <div class="region region-preface-5">
    <div id="block-block-30" class="block block-block thinblock adServe"><div class="block-inner">

	     
  <div class="content">
		<center><ins data-revive-zoneid="40" data-revive-id="57289cd399e96da25652c800dae5885b"></ins>
<!-- <script async src="//www.emmerichmedia.com/ads/www/delivery/asyncjs.php"></script> --></center>  </div>

</div></div>   </div>
    </div></div>  
     
   
    
<!-- All Hail the Footer -->
  <div class="footer-wrapper"><div class="footer-wrapper-inner container_12">
    <footer id="footer" class="grid_12 clearfix">
        <div class="region region-footer">
    <div id="block-block-3" class="block block-block"><div class="block-inner">

	     
  <div class="content">
		 <p align="center" style="font-size: 13.008px;"><span style="font-size: 11px;">Copyright 2018 • The Magee Courer &amp; Simpson County News<br />206 Main Ave. N. • Magee, MS 39111 • (601) 849-3434</span></p>
<p align="center" style="font-size: 13.008px;"><span style="font-size: 11px;">Emmerich Newspapers proudly serve the following Mississippi communities:</span></p>
<p align="center" style="font-size: 13.008px;"><span style="font-size: 11px;">ACKERMAN • CARROLLTON • CHARLESTON • CLARKSDALE • COLUMBIA • EUPORA • FOREST • GREENVILLE • GREENWOOD • HATTIESBURG • JACKSON • KOSCIUSKO • INDIANOLA • LOUISVILLE • MAGEE • MENDENHALL • McCOMB • NEWTON • PETAL • QUITMAN • WINONA • YAZOO CITY</span></p>
<p align="center" style="font-size: 13.008px;"><span style="font-size: 11px;">As well as: DUMAS, Ark. • TALLULAH, La. • FRANKLINTON, La.</span></p>
<p align="center" style="font-size: 13.008px;"><span style="font-size: 11px;">For more information on how to extend your advertising message to these communities, <a href="http://emmerichtestserver1.com/emmerich-contact-form">click here.</a></span></p>
   </div>

</div></div> <div id="block-simpleads-ad-groups-159" class="block block-simpleads"><div class="block-inner">

	     
  <div class="content">
		<div class="header">
  <div class="ad-link"></div>
</div>
<div class="adslist">
  <script type="text/javascript">
    _simpelads_load('.simpleads-159', 159, 1);
  </script>
    <div class="simpleads-159"></div>

    
</div>
  </div>

</div></div>   </div>
      
    </footer><!-- /footer -->
  </div></div>
 
</div><!-- page -->  <script type="text/javascript" src="//www.simpsoncounty.ms/sites/all/modules/addthis/addthis.js?pvi6v4"></script>
</body>

</html>